Обновления безопасности WordPress для версий 3.7-4.0 перестанут поставляться к декабрю 2022

Команда безопасности WordPress объявила о том, что с 1 декабря 2022 года будет прекращена поддержка версий 3.7-4.0. Немного бэкграунда: в 2013 году вышел WordPress 3.7 с автоматическими фоновыми обновлениями, а в версии 3.8 появилась админка с новым дизайном на основе плагина MP6.

Согласно официальной политике WordPress, команда безопасности поддерживает только самую последнюю версию WP. Правда, в качестве исключения специалисты выкатывают патчи безопасности и для более старых версий, которые могут получать автоматические обновления.

«До сих пор бесплатные бэкпорты распространялись на все релизы WordPress, поддерживающие автоматические обновления», — поделился своими мыслями Питер Уилсон, участник группы безопасности. – «Версии WordPress 3.7-4.0 сейчас используются менее чем на 1% установок. В итоге затраченные силы перевешивают плюсы от предоставления этих обновлений».

Более половины всех сайтов на WordPress работают с версиями 6.0+ (54.3%). В итоге обновления безопасности все равно будут доступны для 99% сайтов. Питер отметил, что решение отказаться от поддержки версий 3.7-4.0 основано на статистических данных.

«Подобный дисбаланс означает, что команда безопасности тратит большую часть времени на подготовку бэкпортов для меньшинства пользователей WP», — отметил Питер. – «Отказавшись от поддержки устаревших версий, мы сможем сделать безопаснее новые релизы за счет высвободившихся сил».

В течение следующих трех месяцев релизы до 4.0 продолжат получать обновления. Однако в консоли будет висеть уведомление о том, что необходимо обновиться до свежей версии, поскольку сайты с 1 декабря больше не получат релизов безопасности.

Источник: wptavern.com

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Кнопка «Наверх»